pondělí 12. prosince 2016

Ubuntu Linux - chyba při instalaci deb balíčku - závislosti

Pokud chci nainstalovat např.

$ sudo dpkg -i mysql-workbench-gpl-5.2.34-1ubu1010-amd64.deb

a objeví se tato chyba:

# dpkg -i unifi-video_3.5.2~Ubuntu14.04_amd64.deb
Selecting previously unselected package unifi-video.
(Reading database ... 59342 files and directories currently installed.)
Preparing to unpack unifi-video_3.5.2~Ubuntu14.04_amd64.deb ...
Installed Version
unifi-video: /var/lib/dpkg/tmp.ci/preinst install
Unpacking unifi-video (3.5.2-1) ...
dpkg: dependency problems prevent configuration of unifi-video:
 unifi-video depends on mongodb-10gen (>= 2.4.10) | mongodb-org-server (>= 2.6.0) | mongodb-server (>= 2.4.9); however:
  Package mongodb-10gen is not installed.
  Package mongodb-org-server is not installed.
  Package mongodb-server is not installed.
 unifi-video depends on java7-runtime-headless; however:
  Package java7-runtime-headless is not installed.
 unifi-video depends on jsvc (>= 1.0.15); however:
  Package jsvc is not installed.

dpkg: error processing package unifi-video (--install):
 dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for systemd (229-4ubuntu4) ...
Errors were encountered while processing:
 unifi-video


Znamená to, že při instalaci nebyly splněny některé závislosti.  To můžeme opravit příkazem:

# apt-get -f install

Žádné komentáře:

Okomentovat