úterý 24. února 2015

Spamassassin problém s IPv6

Dnes jsem aktualizoval jeden Linux server. Aktualizace mi skončila předčasně výpisem :

Nastavuji balík spamassassin (3.4.0-1ubuntu2.1) …
Starting SpamAssassin Mail Filter Daemon: server socket setup failed, retry 1: spamd: could not create IO::Socket::INET6 socket on [::1]:783: Požadovanou adresu nelze přiřadit
server socket setup failed, retry 2: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 3: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 4: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 5: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 6: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 7: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 8: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
server socket setup failed, retry 9: spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
spamd: could not create IO::Socket::INET6 socket on [127.0.0.1]:783: Adresa je užívána
invoke-rc.d: initscript spamassassin, action "start" failed.
dpkg: error processing package spamassassin (--configure):
 podproces instalovaný post-installation skript vrátil chybový status 98
dpkg: nesplněné závislosti zamezily konfiguraci balíku sa-compile:
 sa-compile závisí na spamassassin (>= 3.3.2-8); avšak:
  Balík spamassassin zatím není zkonfigurován.

dpkg: error processing package sa-compile (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Žádné apport hlášení nebylo vytvořeno, protože chybová hláška naznačuje, že se jedná o chybu způsobenou předchozí chybou.
                                         Při zpracování nastaly chyby:
 spamassassin
 sa-compile
E: Sub-process /usr/bin/dpkg returned an error code (1)


Protože v síti nepoužívám IPv6, tak jsem upravil konfigurák spamassassina následovně :

$ sudo nano /etc/default/spamassassin

...
OPTIONS="--create-prefs --max-children 5 --helper-home-dir --ipv4-only"
...

A provedl restart služby:

$ sudo service spamassassin restart

Vše proběhlo OK a tak jsem v poklidu mohl dokončit aktualizaci systému.